2.1.2 Software requirements

Under DOS

The dos distribution contains all the files you need to run the compiler and compile Pascal programs.

Under UNIX

Under unix systems (such as linux) you need to have the following programs installed :

  1. gnu as, the gnu assembler.
  2. gnu ld, the gnu linker.
  3. Optionally (but highly recommended) : gnu make. For easy recompiling of the compiler and Run-Time Library, this is needed.

Under Windows

The Windows distributions (both 32 and 64 bit) contain all the files you need to run the compiler and compile Pascal programs. However, it may be a good idea to install the mingw32 tools or the cygwin development tools. Links to both of these tools can be found on http://www.freePascal.org

Under OS/2

While the Free Pascal distribution comes with all necessary tools, it is a good idea to install the EMX extender in order to compile and run programs with the Free Pascal compiler. The EMX extender can be found on:
http://www.leo.org/pub/comp/os/os2/leo/gnu/emx+gcc/index.html

Under Mac OS X

Mac OS X 10.1 or higher is required, and the developer tools or XCode should be installed.